BioFire® COVID-19 Test v1.1 Software Pouch Module – Download Form

In order to run a FilmArray pouch with the FilmArray instrument, a specific Pouch Module must be installed into the FilmArray system software.

Fill out the form to download the BioFire COVID-19 Test v1.1 Pouch Module for the FilmArray Software.

Download the Pouch Module Installation Instructions